Corrupting my IIS 5.1 Metabase and then recovering it!

While trying to install one of the User Group Forums on my machine, the application corrupted my IIS 5.1 (I am running Windows XP)... to start with the only indication that i had was "Internal Error 500" message that IE displayed to me.
Deepak then changed the Internet Explorer setting: Browse -> Show Friendly Error Messages to display extended error message rather than "friendly" error message. Then the error changed to reflect that my IIS metabase has been corrupted.
Now in IIS 5.1, metabase is still a binary file rather than an editable XML (as in IIS 6.0).. so started looking for a utility to edit the bin file.. discovered the Meta Edit Utility. IIS Meta Edit Utility: http://support.microsoft.com/kb/q232068/

Document on working with MetaBase:
http://www.microsoft.com/windows/shared/community/docs/BackupIISMetabase.doc

With all the information at hand tried to edit my metabase but was NOT able to get the configuration right.. so restored the auto saved IIS configuration (if you don't know how to do this you should read the document mentioned above) and recreated my virtual directories..
-------------------------------------------------------------------------------
This posting is provided "AS IS" with no warranties, and confers no rights.

Comments

Anonymous said…
Hey Abhishek

This article of IIS was great help .. YOu made my day.

Thanks a Lot.

Sunil.P
You can find the related tip at http://devfun.blogspot.com

Popular posts from this blog

My family genealogy : Kurmi

How to report software piracy in India

Solving the multi-platform challenge in mobile devices